概念: Docs for Layouts でのドキュメント レイアウトの編集
次のテーブルは、ドキュメント レイアウトの編集時に実行できるアクションの一部をまとめたものです。詳細については、Docs for Layouts ユーザー ガイドを参照してください。このガイドには、Docs for Layouts のユーザー インターフェイスから
"ヘルプ"
>"ユーザー ガイド"
をクリックすることでアクセスできます。アクション | 説明 |
|---|---|
ドキュメント設定を管理 | エディタの左側にある "ドキュメント設定 " アイコンをクリックして、右パネルを開きます。以下を編集できます。
|
ヘッダーとフッターの挿入 | エディタの左側にある ヘッダー アイコンまたは フッター アイコンをクリックして、"ヘッダーを挿入" または "フッターを挿入" を クリックします。
テキスト、画像、テーブル、または水平線の要素を挿入し、右パネルの "形式" タブを使用して形式設定します。ヘッダーまたはフッターを上下に移動するには、ヘッダーまたはフッターの左にある矢印をクリックするか、右パネルの関連アクション メニューから "上へ移動" または "下へ移動" を選択します。ヘッダーまたはフッターを削除するには、まずヘッダーまたはフッター以外の任意の領域をクリックします。次に、右パネルの関連アクション メニューから "ヘッダーを削除" または "フッターを削除" を選択します。 |
ページ番号の挿入 | ページ番号を挿入するヘッダーまたはフッターのテキストまたはテーブル要素を選択します。
ツールバーの "ページ番号" アイコンをクリックして、"現在のページ" または "合計ページ数" を選択します。 |
ページの挿入 | ドキュメント レイアウトでコンテンツを追加すると、ページ領域が自動的に拡張され、ドキュメントを印刷する際にページ分割が自動的に作成されます。 新しいページを手動で追加するには、既存のコンテンツの下にあるレイアウトの最後にある "新しいページを追加" をクリックします。新しいページは、レイアウトの最後に追加されます。他のページの間にページを挿入することはできません。ページを削除するには、削除するページをクリックします。右パネルの "形式 " タブで、"削除" をクリックします。 |
背景画像の挿入 | "挿入 " >"背景画像" を選択し、背景画像を挿入するページを選択します。"画像の選択" を クリックし、画像を選択して "保存" をクリックします。
背景画像を複数のページに表示するには、手動で新しいページを追加してから、それぞれのページに背景画像を個別に追加する必要があります。 背景画像を削除するには、 "挿入" >"背景画像" を選択し、"背景画像の削除" を クリックします。 |
テキスト、テーブル、画像の挿入 | エディタの左側にある "テキストの挿入" 、"テーブルの挿入" 、"画像の挿入" 、または "横線の挿入 " アイコンをクリックします。
既存の要素の上、下、または横にカーソルを合わせます。青色のインジケータが表示されて、クリックして要素を挿入できる場所を示します。 要素を削除するには、その要素を選択し、右パネルの "形式 " タブから "削除" を クリックします。要素を移動するには、その要素を選択して、右パネルの "形式" タブから "移動" をクリックします。カーソルを新しい場所に移動し、要素を配置するためにクリックします。 |
動的データ フィールドの挿入 | テキストまたはテーブル要素のテキスト領域をクリックします。右パネルの "動的データ" タブで、挿入するデータ フィールドの横にある + アイコンをクリックします。データ フィールドは、点線の下線と緑の背景を含むテキストとして要素に表示されます。
データ フィールドを削除するには、そのフィールドを選択して Delete キーを押します。データ フィールドのすべてのインスタンスを別のものに置き換えるには、右パネルの "動的データ" タブでそのデータ フィールドを探します。パネルのデータ フィールドの横にある関連アクション メニューから、"すべて置換" をクリックします。次に、挿入する新しいデータ フィールドを探し、"データを置換" アイコンをクリックします。 |
動的チェックボックスを挿入 | テキストまたはテーブル要素のテキスト領域をクリックし、ツールバー内の チェックボックス アイコンをクリックします。チェックボックスのブール値データ フィールドを選択し、"挿入" をクリックします。このチェックボックスは、緑の背景でオンになっている状態でレイアウトに表示されます。
ドキュメント レイアウトを印刷すると、関連付けられているデータ フィールドに応じて、チェックボックスがオン (真) またはオフ (偽) として表示されます。 チェックボックスを削除するには、そのチェックボックスをクリックして Delete キーを押します。 |
動的画像の挿入 | 社員の写真など、データ フィールドに関連付けられている画像のプレースホルダを挿入できます。画像のプレースホルダはそれぞれの要素内に含まれており、テキスト、テーブル、画像要素など、ページ上の任意の場所に配置できます。
右パネルの "動的データ" タブで動的画像を探し、挿入する画像の横にある "画像プレースホルダ " アイコン (+ 記号の付いたメモ) をクリックします。既存の要素の上、下、または横にカーソルを合わせます。青色のインジケータが表示されて、クリックして画像プレースホルダを挿入できる場所が示されます。画像プレースホルダ 緑の背景に空の三角形として表示されます。 画像プレースホルダを削除するには、それを選択して右パネルの " 形式 " タブから "削除" をクリックします。画像プレースホルダを移動するには、それを選択して右パネルの "形式 " タブから "移動" をクリックします。カーソルを新しい場所に移動し、画像のプレースホルダを配置するためにクリックします。 |
条件ルールを適用してください | ドキュメント レイアウトに関連付けられたレポートにブール値 (真/偽) データ フィールドがある場合、それらのフィールドが自動的に条件ルールとして使用可能になり、レイアウトに適用してコンテンツの表示と非表示にすることができます。レポートの数値、テキスト、自己参照、および単一インスタンス データのフィールドを使用して、カスタム条件ルールを作成することもできます。ドキュメントの生成時に条件が真の場合は、条件付きのコンテンツが表示されます。条件が偽の場合は、コンテンツは非表示になります。
条件ルールをコンテンツに適用するには、テキストまたは要素を選択します。右パネルの "条件" タブで、適用する条件の横にある + アイコンをクリックします。条件の横に表示される有色人種のアイコンは、適用したページのテキストまたは要素の背景色と一致します。眼科インジケータをクリックして、ページ上の関連コンテンツを表示または非表示にします。 |
小計値の挿入 | 繰り返しデータ行と数値または通貨データ フィールドを含むテーブルのデータをグループ化して小計を計算することができます。テーブル行を作成するときは、最初の列にグループ化する繰返しデータ フィールドを最初の列に挿入し、最後の列に小計に数値または通貨のデータ フィールドを挿入します。次に、小計を計算するテーブル行を選択し、右パネルの " 形式" タブで "小計の繰返し表示の行" トグルをクリックします。 |